SAP Knowledge Base Article - Public

3551615 - Incorrect calculation of Start and End Dates for maintenance order in SAP S/4HANA Cloud Public Edition

Symptom

  • The required date in the maintenance order is not calculated correctly based on the priority setting.
  • Despite setting the priority as for example, 3 days, the start date and end date show a 5-day gap.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Maintain the priority as 3 days in SSCUI - Define Priorities for Each Priority Type.
  2. Create an order and observe the start and end dates are not expected.

Cause

This is standard system behavior.

Resolution

  1. System automatically skips holidays while setting start/end dates.
  2. A warning message will appear when manually set the date to a holiday.
  3. For instance, if the start date is 11/13/2024 and the priority is 'Normal' (3 days), the end date will be 11/18/2024 as 11/16/2024 and 11/17/2024 are non-working days according to Plant Factory calendar.

Keywords

Maintenance order, start date, end date, priority, date calculation, non-working day, factory calendar , KBA , PM-WOC-MO-2CL , Maintenance Orders (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions