Symptom
After maintaining the Postal Code mandatory for a given Country, it is still possible to create the Lead (for this same Country) without maintaining the Postal Code.
Environment
SAP Sales Cloud and SAP Service Cloud Version 2
Reproducing the Issue
- Go to Leads View.
- Click "+" to create a new Lead.
- Select Prospect and fulfill the necessary fields.
- Do not maintain a Postal Code.
- Click Save and Open: Lead is created successfully.
Also, if you select an Existing Account from USA (instead of Prospect), the Postal Code also does not become mandatory.
Cause
The relevant settings applies to Contacts and Accounts, not to Lead prospects (until converted to Contact/Account).
Prospect Leads are no full fledged accounts yet. When a sales agent creates prospect Leads, initially they are rather "incomplete".
Additional data is added as they are processed until they are ready to be converted to their final business entity (e.g. an opportunity with an account and contact), containing all necessary information to enable the sales agent to execute upon the sale.
Therefore mandatory properties on Lead prospects are not enforced before conversion to Account/Contacts.
Resolution
This is the current system behavior.
However, if there is a business requirement to enforce specific properties to be mandatory (e.g. at a specific stage of the Lead process) then it is possible to enforce this by adding a Custom Validation in Extensibility settings.
Keywords
Lead , Postal Code , Country , Mandatory , Create , Region , KBA , CEC-CRM-LEA , Lead for SAP Sales/Service Cloud , Problem