Symptom
You are unable to edit fields such as Function, Job Title, Department, Business Department, Phone, Mobile, Status, Language etc as these fields are greyed out in the Contact creation screen
Environment
-
SAP Sales Cloud and SAP Service Cloud Version 2
Reproducing the Issue
- Go to Navigation Menu
- Go to Contacts
- Click on + icon
- Observation: Some fields such as Function, Job Title, Department, Business Department, Phone, Mobile, Status, Language are greyed out
Cause
Account field is blank or no data is present in the Account field.
These fields belong to the Contact Person Workplace Address, but a Contact can only have a Workplace Address if he has a "is contact person for" relationship to an Account.
This is the reason why these fields are only editable if the Account field is filled.
Resolution
Enter data in the Account field.
See Also
3533187 - Contact Address is different from Account's Address
3519661 - Uploading Contact Phone Number and Email using Data Impex tool
3563808 - Able to Remove Contact from Account although Account is a Mandatory Field in Contact
Keywords
account, contact, job, fields, function, mobile, job title, department, editable, , KBA , CEC-CRM-CON , Contact for SAP Sales/Service Cloud , Problem
SAP Knowledge Base Article - Public