Symptom
When you create a Business Partner in S/4 and check for replication, you may find that the BP hasn't been replicated.
The following error can be observed for the entity businessPartnerS4ReplicationMessageIn: "Role CRM002 does not exist"
Environment
SAP Sales Cloud Version 2
S/4Hana Cloud
Reproducing the Issue
- Create or Change a Business Partner in S4 in order to push the replication towards CNS
- Log in CNS
- Go to Settings
- Go to Message Monitoring
- Filter by the entity: sap.crm.md.integrationmetadataservice.entity.businessPartnerS4ReplicationMessageIn
Error Details outline the following: Role CRM002 does not exist
Cause
This indicates that the role assigned to the Business Partner you attempted to replicate is incorrect, preventing successful replication.
Resolution
Delete the existing Business Partner in S/4 HANA and create a new one with the role of "Sold-to-Party."
Keywords
CRM002;businessPartnerS4ReplicationMessageIn;Sold-to-Party , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , Known Error