Symptom
When replicating Business Partner from CRM/S4H to C4C the Industry field is getting removed/deleted although the relevant information is already available in the payload.
Environment
- Cloud for Customer integration with S/4HANA
- Cloud for Customer integration with ERP
Reproducing the Issue
- Go to Administrator Work center.
- Open the General Settings View.
- Click on Web Service Message Monitoring.
- Search for the Service Interface/message.
- Open this message and observe that the values are available.
- Go to Customer Work center.
- Open the Customer View and open the customer
- See that the Industry field was deleted or not updated.
Cause
This is happening because you have not maintained the IndustrialSectorCode and IndustryClassificationSystemCode in the Code List Mapping for Integration with External Applications and Solutions.
You can check on the C4C payload the following to confirm the behavior:
<IndustrySector actionCode="04">
<IndustryClassificationSystemCode>123</IndustryClassificationSystemCode>
<IndustrialSectorCode>123</IndustrialSectorCode>
<DefaultIndicator>false</DefaultIndicator>
<IndustrialSectorCode> it should be maintained under Local Data Type Name: IndustrialSectorCode
<IndustryClassificationSystemCode>it should be maintained under Local Data Type Name: IndustryClassificationSystemCode
Resolution
You must make the IndustrialSectorCode and IndustryClassificationSystemCode are maintained properly.
See Also
Keywords
Industry field. , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , Problem