SAP Knowledge Base Article - Public

3552863 - When integrating C4C with SAP Marketing cloud the error "Object identifier type XXX does not exist in /YYYY" appears in SAP Marketing cloud

Symptom

When integrating Business Partner relationships between C4C and SAP Marketing cloud the error "Object identifier type XXX does not exist in /YYYY" appears in SAP Marketing cloud, where XXX represents the Object identifier type in the incoming payload and YYYY represents the Marketing cloud system.

Environment

  • SAP Cloud for Customer 
  • SAP Marketing Cloud

Reproducing the Issue

  1. Open the C4C, navigate to the Customers work center.
  2. Open any Account and add a new Contact on the Account, save the new Contact.
  3. The Relationship data is sent to SAP Marketing cloud.
  4. Open the SAP Marketing cloud system.
  5. Navigate to the Import Monitor and search for the error message "object identifier type XXX does not exist in /YYYY".

 

Cause

The incorrect communication arrangement is being used for the ID mapping in the C4C system, "Replicate ID Mapping to SAP Business Suite".

Resolution

Please activate the Communication Arrangement "Replicate Business Partner ID Mapping to SAP Business Suite" in C4C and send the relationship message again.

Keywords

ID mapping, Business Partner, Relationship, Communication Arrangement, Replicate ID Mapping to SAP Business Suite, Replicate Business Partner ID Mapping to SAP Business Suite, Customer, account, Contact, object identifier type does not exist in , KBA , LOD-CRM-INT-YMT , Integration of C4C with Marketing , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions ; SAP S/4HANA Cloud Public Edition all versions