SAP Knowledge Base Article - Public

3553434 - After the candidate signs forms using DocuSign, the e-signature step does not appear to have been completed - Onboarding

Symptom

The candidate has signed the form with DocuSign, but step "Complete E-Signature" is still open and not shown to be completed. The candidate also does not appear on the "Manage Pending Hires" page.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. The candidate has signed the form with DocuSign
  2. Step "Complete E-Signature" is still open and not shown to be completed

Cause

Document Management Services used is "OpenText" and there is an error during document storage in attachment service. 

Resolution

  1. Open a ticket to the LOD-SF-OBX-FRM module and let Product Support Engineer check the log to determine which form is faulty.
  2. Remove the affected form from business rule, after that all the other forms will trigger for affected candidate.
  3. Go to BPE: Manage Process Tasks >Click Filter button>Search by using job id: xxxxxxx> Click "Apply"
  4. Select the task and click the "Restart Task" button

How to find the job id:

  1. Go to "BPE:Monitor Processes"
  2. Click the filter button
  3. In Variable, search "userId=xxxx" (the userId is the candidate's userid)
  4. Click "Apply"
  5. You will find the unfinished task related to document
  6. Copy the start time
  7. Open a new page to "BPE:Monitor Processes"
  8. Near the start time there is an unfinished record named "documents.Onboarding2Document...."
  9. Select the record and you will find the job id with error id

Keywords

OPENTEXT, DocuSign, Document Management Services, attachment service, Complete E-Signature , KBA , LOD-SF-OBX-FRM , Compliance 2.0 Country Forms (except i9&EV) , Problem

Product

SAP SuccessFactors Onboarding