SAP Knowledge Base Article - Public

3553542 - Data missing in offline mode

Symptom

Custom EC data are not display in Offline Mode

Environment

  • SAP Cloud Application Studio.
  • SAP Cloud for Customer.
  • SAP Business ByDesign.

Reproducing the Issue

  1. Go to the Visits work center view.
  2. Open the visit with ID 1.
  3. Navigate to the Custom EC tab, where you should be able to see the entries.
  4. Click on the User icon.
  5. Go to the Offline Model.
  6. Open the visit with ID 1.
  7. Notice that the records in the Custom EC tab are not visible.

Cause

The secondary relationship can be defined in the custom object using the annotation [OfflineSecondary] at the element declaration in the BO definition.


/YABCDEFGH_MAIN/SRC/CustomBO.bo

[OfflineEnabled]businessobject CustomBO {

        [OfflineSecondary(AP.PC.ActivityManagement.Global:Activity.UUID)][AlternativeKey][Label("Visit UUID")]    element VisitUUID                : UUID;

}
    

There is an inconsistence with deployment of the secondary relationship mapped between the BO Activity and the CustomBO.

The reason is that multiple Custom BOs will deployed at the same time,  leading to conflicts.
         

Resolution

Please reactivate the /YABCDEFGH_MAIN/SRC/CustomBO.bo If the issue persists, kindly open a case request backend active with the component AP-RC-BDS-OFL. 

Recommendation: Adminstrator->Offline Settings->Related Data Download set the default setting to "Only first level" and not "All" for performance reasons. 

The "All" setting typically does not serve a business need in all scenarios. You can maintain specific exceptions in the table below if necessary. 

Keywords

offline,Custom BO,Custom EC,no data,OfflineSecondary , KBA , AP-RC-BDS-OFL , PDI Offline Enhancements , AP-RC-BDS-BO , ByDesign Studio BO definition/generation , Problem

Product

SAP Business ByDesign all versions ; SAP Cloud Applications Studio all versions ; SAP Cloud for Customer core applications all versions