Symptom
Once create a visit in Outlook, error raised and interrupt you create in OWA, but the same step works on desk Outlook App.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Open the OWA in website.
- Go to Calendar and create a new event
- Click SAP Cloud for Customer icon
- Search an account and click on "save this item"
- Change to Visit BO in save the item as
- Error raised once you click on save
Cause
Once you create a visit in OWA, the detailed information like title and attendee cannot be empty.
Resolution
Once you maintained the related information, the item can be saved as Visit.
This is an expected behavior for OWA (controlled by Microsoft). The difference happens on OWA and desk app is because there is no cache in OWA. Once you close an email which edited, in desk app, it allows you save the changes as a draft before sending, but in OWA, you'll leave with nothing saved.
By this, once you save in desk app, you'll able to see there is a message "This item is saved to SAP Cloud for Customer once it is sent.", this means, the item is just temporary saved in your outlook, if you check C4C, the visit not created, only when the email sent successfully, it will sync to C4C. But for OWA, it does not have such function like draft, the browser won't remember the information which you haven't saved, so the item cannot temporary saved in email, it will create visit directly, so it requests you fill in all details.
Issue will be solved after you maintain the title, address and related information.
Keywords
OWA, Object Web Access, Outlook desk app, server side integration, new outlook, create visit , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , Problem
Product
Attachments
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