Symptom
When you try to depersonalize a Ticket, you get the error message "Action DESTROY not possible; action is disabled"
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Service work center
- Open the Ticket you want to depersonalize
- Click depersonalize in More options.
- Error message is received.
Cause
You are trying to depersonalize an already depersonalized Ticket.
Resolution
We cannot Depersonalize an already depersonalized ticket and this is the expected behavior. A Depersonalized ticket subject changes to XXXXXXXXXX
The Depersonalize of Ticket does not mean the Deletion of Ticket.
When you depersonalize a ticket, the system makes the personal information associated with that ticket anonymous. All references within the ticket are removed. Hence, when you open a ticket after depersonalization, you won't see any information related to the contact, customer, or employee associated with the ticket. The information you see depends on the Read-Access-Login information.
Also please note that it is not possible to Delete a Ticket on production systems. You can however set it to "Irrelevant" if you do not want the Ticket to appear in the Tickets Query. (Irrelevant Ticket can still be seen in "All Irrelevant Tickets" query).
Keywords
KBA , LOD-CRM-SRP , Service Request Processing , Problem