Symptom
I-9 and Compliance form keeps on loading without seeing any document
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Login as a candidate
- Attempt to trigger I-9 or compliance forms
- Page is stuck in loading
Cause
This issue may root down on multiple causes but for this specific guide, it may be due to that the area-code field was removed or disabled
Resolution
Enable the area-code field from Manage Business Configuration under phoneInfo entity. Area Code field in the Employee Central data model is mandatory in Form I-9 and should be enabled.
See Also
Keywords
Compliance forms, not triggering, obx, area-code, loading, stuck, I-9 , KBA , LOD-SF-OBX-FRM , Compliance 2.0 Country Forms (except i9&EV) , Problem
Product
SAP SuccessFactors Onboarding all versions