SAP Knowledge Base Article - Public

3554907 - I-9 and compliance forms keep on loading for over a minute - Onboarding

Symptom

I-9 and Compliance form keeps on loading without seeing any document

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Login as a candidate
  2. Attempt to trigger I-9 or compliance forms
  3. Page is stuck in loading

Cause

This issue may root down on multiple causes but for this specific guide, it may be due to that the area-code field was removed or disabled

Resolution

Enable the area-code field from Manage Business Configuration under phoneInfo entity. Area Code field in the Employee Central data model is mandatory in Form I-9 and should be enabled.

See Also

3465319 "Unable to fetch form data" error is received when completing some of the SWH tax forms due to disabled 'area-code' field - Onboarding 

Keywords

Compliance forms, not triggering, obx, area-code, loading, stuck, I-9 , KBA , LOD-SF-OBX-FRM , Compliance 2.0 Country Forms (except i9&EV) , Problem

Product

SAP SuccessFactors Onboarding all versions