SAP Knowledge Base Article - Public

3554923 - Data not Displayed When Opening an Email Activity

Symptom

When accessing the Email Activity ABC through the Account Management workcenter, no data is displayed (where ABC represents the Email Activity subject).

Environment

SAP Business ByDesign

Reproducing the Issue

 

  1. Navigate to the Account Management workcenter.
  2. Go to the Activities view.
  3. Filter for All Email Activities.
  4. Search for ABC on the Search Bar.
  5. Select the activity and click on Edit.

Nothing is displayed, as the user were creating a new Email Activity.

  1. Now, go to the system's general Search field (on the top right corner of the screen).
  2. Search for ABC.
  3. On the All Categories tab, the Email Activity ABC is under Business Documents. Open it.

The data is displayed with no errors.

Cause

The relevant backend table is not filled in the moment that the Activity is opened.

Since the entry is not available, the data related to the email does not get displayed.

Resolution

In order to refresh the record and properly display data for the email activity, follow the below steps:

  1. Open the Activity ABC through the system's general Search field.
  2. Click on Change Status.
  3. Change it to a different one.
  4. Click on Save.
  5. Change it back to the original Status.
  6. Save it again.

Now, the data is refreshed and it is possible to access the Activity through the Account Management workcenter.

Keywords

activity, email, account management, not displayed, no content, no data, missing, byd. , KBA , SRD-CRM-ACT , Activities , How To

Product

SAP Business ByDesign all versions