Symptom
- Employees with multiple employments cannot see the existing jobs applied from the candidate profile page.
- Employees with multiple employments cannot open the URL to the Online Offer Letter / DocuSign and encounter an error page displaying "Looks like something went wrong".
- Unable to switch employment on Internal Career Site Powered by Career Site Builder (CSB).
Environment
- SAP SuccessFactors Recruiting Management
- SAP SuccessFactors Recruiting Marketing
Reproducing the Issue
- An employee in Global Assignment logs in to the system.
- Switch to the Home Employment using the Employment Switcher.
- Navigate to Home > Careers.
- Click on My Account > View Profile.
- A blank candidate profile opens. No jobs applied are available.
- When trying to open the link to the offer letter, an error page "Looks like something went wrong" is displayed.
Cause
When an employee has multiple employments, each employment has its own independent candidate profile. Consequently, the employee is unable to access job applications and offer letters associated with other employments.
This behavior is consistent with the Single Sign-On (SSO) login behavior described in the KBA 3406308.
The SSO login behavior for Global Assignment (GA) is:
When user has an active Global Assignment, no matter using which account name to login, the system will consistently redirect the user to Global Assignment, this behavior persists until the user returns from Global Assignment (GA ended).
The SSO login behavior for Concurrent Employment (CE) is:
If Concurrent Employment is the primary assignment and active, the user will be redirected to Concurrent Employment upon login.
Resolution
Currently, there are no options to switch the employment profile when using the Internal Career Site powered by Career Site Builder (CSB).
If this functionality is important for your business and you would like to request an improvement, please submit it to our Customer Influence Page. This platform enables users to vote for each other's ideas, post comments, and receive direct feedback from the Product Management team. Refer to the KBA 2090228 for more information.
This situation would only occur during the transition phase where internal candidates already have an job application and offer letter generated for a different employment. Here are possible workarounds:
For Global Assignment (GA):
The employee can re-apply for the Job Requisition from the GA candidate profile, and a new offer letter can be created against this profile.
Please note that once the Global Assignment is active, the candidate will not have the option to access the internal candidate profile associated with the Home Employment.
If an offer letter has been initiated for the Home Employment, the employee must accept it before the start of the Global Assignment. Backward compatibility of generated offers on previous User IDs is not supported.
For Concurrent Employment (CE):
The administrator can temporarily switch the Concurrent Employment to the "Secondary Employment", making the original Home Employment the primary. This will allow the employee to log in to the Home Employment candidate profile upon SSO.
For detailed steps, refer to the KBA 3327465 - How to change the Primary/Secondary employment for an employee.
See Also
Help Portal: Internal Career Site Powered by Career Site Builder
Keywords
RCM, RMK, ICS, login account, candidate profile, Single Sign On, SSO, secondary, primary, employment, home employment, global assignment, concurrent employment, offer letter, error, view, unable to accept , KBA , LOD-SF-RMK-ICS , Internal Career Site Builder (CSB, IAS, etc ...) , LOD-SF-RCM-CAO , Candidate Offers, Offer Letters , Problem