SAP Knowledge Base Article - Public

3555415 - Unable to add the custom fields in app 'My Inbox Approve purchase order'

Symptom

Unable to add the custom field in app 'My Inbox Approve purchase order' as "Activate" and "Publish New Version" buttons are not available.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Go to My Inbox app,
  2. Select any PR /PO / invoice to approve
  3. Click on Adapt UI
  4. Click on add custom fields
  5. After adding a custom field to the application, the custom field disappears upon closing and reopening the application

Cause

A custom field can be added to the My Inbox screen; however, the "Activate" and "Publish New Version" buttons are not available to save the changes.

This behavior is expected because the "My Inbox" application does not currently support UI adaptation.

Resolution

To make UI adaptations, navigate to the Purchase Order apps and perform the changes there. For further information, refer to the documentation Extensibility for Purchase Order Apps 

Note : To request this feature for implementation in a future version, consider submitting a future request in the customer influence portal as per KBA 11 - Would you like to shape & influence future releases of SAP Products? - SAP for Me 

Keywords

My Inbox, Custom Field, Adapt UI, My Inbox" application does not currently support UI adaptation, Unable to add the custom fields in app 'My Inbox Approve purchase order', 'My Inbox Approve purchase order' PR /PO / invoice , KBA , BC-SRV-APS-EXT-FLD , Custom Fields , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions