Symptom
You are restarting application error for a specific interface with a huge amount of data (for example around 100.000) and a dump with a standard error is raised and you need to close the object.
The error occurs when you use the restart functionality by "Based on filter criteria" from web message monitoring tool.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Administrator work center.
- Go to the General Setting work center view.
- Open the Web Service Message Monitoring under System Administration.
- Choose "Erroneous" query.
- Filter by Service Interface field in advanced search and press Go.
- Choose Restart button, specifically "Based on filter criteria" action.
Cause
The limit of data you are trying to restart at once is bigger than the limit of records allowed by C4C, which is under 1000 records.
It excepts the system offset and the dump appears.
Resolution
In order to resolve the issue, you will need to restart the message in batches of 1000 records. You can do the following:
- Go to the Administrator work center.
- Go to the General Setting work center view.
- Open the Web Service Message Monitoring under System Administration.
- Choose "Erroneous" query.
- Filter by Service Interface field in advanced search and press Go.
- Click on the "Select" box next to the "Status"
- Use the Restart button and hit Selected.
Keywords
C4C, Cloud for Customer, Web Service Message Monitoring, Web Service, Message, Monitoring, Dump, Restart, Huge Amount, Application Errors, Based on Filter Criteria, Erroneous, , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To