Symptom
After the rejection of a sales order, the status of the order remains as "In Approval" instead of changing to "Rejected".
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Create a sales order in the SAP S/4HANA Cloud Public Edition.
- The sales order is rejected by the approver.
- The status of the sales order remains as "In Approval" instead of changing to "Rejected".
Cause
The issue is caused by a missing configuration.
Resolution
Check the workflow step logs and maintain the corresponding Rejection Reason through the configuration activity "Assign Rejection Reasons to Sales Document Types and Sales Organizations" (ID: 101882).
See Also
Keywords
SAP S/4HANA Cloud Public Edition, Sales Order, Approval Status, Rejection, Configuration, Rejection Reason 77, Order Type OR, Sales Org 1000, Assign Rejection Reasons, Sales Document Types, Sales Organizations, Approval Flow, reject, rejecting, In Approval, 101882, Assign Rejection Reasons to Sales Document Types and Sales Organizations , KBA , SD-SLS-2CL , Sales (Public Cloud) , SD-SLS-SO-2CL , Sales Orders (Public Cloud) , Problem