Symptom
The ticket status is not changing despite a PDI logic that triggers this update.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the work center Service, view Tickets.
- Open the ticket and perform the steps that trigger your PDI logic.
- Save.
The status does not change despite your PDI logic. Alternatively, you may also encounter this error message: "Inconsistency in status management between system status and status", even though the status mapping is done correctly as per the KBA 3040917.
Cause
The status cannot be updated through events like "Before Save" or "After Modify" as it is SAM action (Status and Action management). This is a current limitation from SAP side.
Resolution
You can make use of workflows to update the ticket status.
See Also
KBA 3040917 - Inconsistency In Status Management Between System Status And Status
Keywords
ticket, status, pdi, update not working, field not changing, Inconsistency in status management between system status and status , KBA , LOD-CRM-SRP , Service Request Processing , How To