SAP Knowledge Base Article - Public

3555942 - Understanding Blank Name Fields in Change Audit Report

Symptom

In Change Audit Reports, some fields such as "Changed By User (First Name)" or "Changed By User (Last Name)" appear blank for certain records, even though the "Changed By User (Username)" field is populated.

Environment

SAP SuccessFactors HCM Suite

Reproducing the Issue

  1. Generate a Personal Change Audit Report
  2. Observe that for some fields such as "Changed By User (First Name)" or "Changed By User (Last Name)" are blank

Cause

The cause could be one of the following:  

  • Change is made by an API, for API related trigger whether or not the Changed By is record depends on the logic of the API ( an API will indicate whether the modifier is recorded)

Or

  • The first name and last name in Change Audit Reports are derived from the Personal Information section of the user. In some cases, the first name and last name fields of users can be missing in the "Personal Information" Portlet.

NOTE: Even if the user left the company and is no longer in the system, the information should be retained and appear in the audit report. 

Resolution

For the API changes, raise a case with support under component LOD-SF-PLT-CHA if further details are needed on a specific record with the details of the API used, what the input data of the API when changing the configuration of the static group.

For the first name and last name fields of users missing in the "Personal Information" Portlet, adding the missing 'first name' and 'last name' information for the affected user ensures its name to be properly displayed in future audit reports.

See Also

SAP Help - Creating Change Audit Reports

Keywords

Change Audit Report, Blank Fields, Personal Information, User Details, SAP SuccessFactors, first name, last name, sf , KBA , LOD-SF-PLT-AUDR , Request Audit Report (Not Change Audit) , How To

Product

SAP SuccessFactors HCM Suite all versions