Symptom
The account was set to obsolete via replication. After that, the same account was updated once again via a technical user, and the status remained obsolete instead of being changed to active, even though the deleted indicator was set to false.
Environment
- SAP Cloud for Customer
- S/4HANA
- Master Data Management
- ERP
Reproducing the Issue
- Go to the Customer work center.
- Go to the Accounts work view.
- Search for the Account 12345 (where 12345 refers to the Account ID).
- The status is Obsolete.
- Go to the Administrator work center.
- Go to the General Setting work center view.
- Open the Web Service Message Monitoring under System Administration.
- Select query All.
- Expand Advanced filter.
- Search for Internal Object ID 12345.
- Click on View > Payload.
You can see the incoming payload has <DeletedIndicator>false</DeletedIndicator>
Cause
When activating the business partner on the external system, the Released Indicator has to be set to true and the Deleted Indicator to false as per the following:
<ReleasedIndicator>true</ReleasedIndicator>
<BlockedIndicator>false</BlockedIndicator>
<DeletedIndicator>false</DeletedIndicator>
Resolution
In this situation, you may need to set the released indicator to true than this will re-activate the customer in C4C.
Keywords
Account, Obsolete, Activated, External System, MDG, S/4HANA, ERP, Replicated to, Replication, Active, C4C, Cloud for Customer, ReleasedIndicator, False, DeletedIndicator, True. , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To