Symptom
When responsible user attempts to proceed with the first rehire check, an application error occurs, blocking the task submission.
The issue is specific to one particular rehire candidate. The same user can successfully proceed with other rehirings, has all the necessary permissions and is part of the dynamic group.
Environment
SAP SuccessFactors Onboarding
Cause
PaymentInformationV3: The payment information is being added without including the associated parent information, which triggers the error.
Resolution
To successfully proceed and initiate the affected candidate in Onboarding, you will need to delete the candidate's Payment Information section and retry completing the step.
Note: Deleting the payment information removes the pay details from the candidate's record. The payment details will need to be manually re-added to the candidate's EC profile.
Keywords
rehire, first, check, block. blocked, unable, continue, proceed, save, submit, application, error, Onboarding, OBX, PaymentInformationV3, RowId shouldn't be Null, we are trying to access the SmartGenericObject's getRelationshipEOs before even all the fields values are set in the parent, FieldRankComparator, parentEO , KBA , LOD-SF-OBX-RHM , Rehire Mechanism , Problem