SAP Knowledge Base Article - Public

3556108 - Error: "Given request ID does not exist" Cybersource and SAP Digital Payments Add-on

Symptom

  • An error "Given request ID does not exist" is encountered while performing credit card registration with SAP Digital Payments Add-on (DPA).
  • The error occurs during the card registration with DPA, despite the request ID existing on the Cybersource side.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Perform credit card tokenization with Cybersource to obtain the subscription ID and request ID.
  2. Register the card with DPA using the /core/v1/tokens/getforpaymentcard endpoint, passing the subscription ID and request ID obtained in step 1.

Cause

The issue is not a DPA issue. It is recommended by Cybersource to implement a retry policy before requesting the prepare call.

Resolution

"Important: After you run any authorization or tokenization request directly through
Cybersource, Cybersource recommends that you implement a retry policy before you request
the prepare call. For example, you could implement a policy to attempt retries every 0.5
seconds after the initial prepare call. This delay provides enough time for the data to reach all
available data sources utilized by our Transaction Search functionality and ensures that SAP
receives consistent data. Cybersource is working to improve or remove any need for a delay
in the future."

SAP recommendation is to attempt retries in more than 0.5 seconds.

 
 
 

See Also

Refer to the Cybersource integration guide: https://docs.cybersource.com/content/dam/new-documentation/documentation/en/partner-solutions/developer/all/rest/sap-dpa-integration-rest.pdf  

Keywords

SAP Digital Payments Add-on, DPA, Cybersource, credit card registration, request ID does not exist, retry policy, prepare call, transaction search functionality, latency. , KBA , FIN-FSCM-DP-DP , SAP digital payments add-on , Problem

Product

SAP S/4HANA Cloud Public Edition all versions