SAP Knowledge Base Article - Public

3556455 - Field Not Available in the List While Creating a Rule

Symptom

Some standard fields are not available in the list of fields while creating a rule in adaptation mode

Environment

SAP Cloud for Customer

Reproducing the Issue

1. Login to C4C.

2. Open any BO workcenter.

3. Navigate to the TI of a record containing the extension field (code + value field) in the header.

Cause

If the field is not enabled for Offline mode or field is dynamic, the rules cannot be set for standard field. (Please note: These can be checked only from SAP end as it depends on the application logic bound to the field). 

Resolution

This is an expected system behavior.

Keywords

Standard field not available in Rule, Rule editor; rule field , KBA , AP-RC-UIF , C4C UI Framework , AP-RC-UIF-FLX , Page Layout & Key User Configuration , Problem

Product

SAP Cloud for Customer core applications 2411