Symptom
- When incorrect information is submitted in the I-9 Section 2 task (for example, a wrong Social Security Number), an error is generated as expected.
- However, the I-9 User Data status incorrectly updates to 'Section 2 Submitted' despite the error.
- This status should remain as 'Section 1 Signed' until the I-9 Section 2 task is successfully submitted.
- As a result, manual intervention is required to correct the I-9 User Data status back to 'Section 1 Signed' before the 'Correct Form I-9 Data' task can be initiated.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Complete the personal data collection step as well as the I-9 section 1 & e-signature task.
- Verify the I-9 User Data status is in the 'Section 1 Signed' status (expected).
- Proxy in as the admin and fill out the I-9 Section 2 with incorrect information (wrong SSN works best).
- Try to submit the I-9 section 2 task - verify the error populates stating the information entered doesn’t match the records for the user.
- Check the I-9 User Data again - status should still be 'Section 1 Signed', not 'Section 2 Submitted'.
Cause
The issue arises due to a system behavior where the I-9 User Data status incorrectly updates to 'Section 2 Submitted' when an error is encountered during the submission of the I-9 Section 2 task.
Resolution
- There is no patch fix on this issue. It was released in normal cycle as part of 2411 - Though the status still reflects Section2 submitted on the SSN error pop-up, it is not a blocker, and we can initiate Section 1 correction.
- There is no need in workaround anymore. SSN should be corrected via 'New Hire Data' from dashboard. If I9 Section 1 is not submitted yet then SSN changes will be reflected immediately. For rest cases need to initiate I-9 Section 1 Correction.
Keywords
obx, Onboarding, I-9 Section 2, User Data status, incorrect update, error, SSN, Section 1 Signed, Section 2 Submitted, New Hire Data, I-9 Section 1 Correction, , KBA , LOD-SF-OBX-FRM , Compliance 2.0 Country Forms (except i9&EV) , Problem
Product
SAP SuccessFactors Onboarding all versions