Symptom
Error on scheduled autoflow: "Scheduled record invalidated, planned duration time is passed."
Environment
- SAP Service Cloud v2
- SAP Sales Cloud v2
Reproducing the Issue
- Go to Settings.
- Open Autoflow view.
- Click on the 3 dots and select rule logs.
- Select schedule rules query.
- Open the log for affected rule.
- You will see the error: Scheduled record invalidated,planned duration time is passed.
Cause
For example, you have set a schedule condition for 'Valid To' field in sales quote entity and the 'Valid To' date is in the past. Since the field value is in the past, you shall see "Scheduled record invalidated, planned duration time is passed" in the logs.
Resolution
The autoflow should be triggered for any new record that is created or an existing one that is updated manually, where the field date e.g. 'Valid To' is in the future.
Keywords
Autoflow, Scheduled, Past, Duration, Time, Passed , KBA , CEC-CRM-AFL , Autoflow for SAP Sales/Service Cloud , How To