SAP Knowledge Base Article - Public

3556976 - Error 'Schedule Record Invalidated' in Autoflow

Symptom

Error on scheduled autoflow: "Scheduled record invalidated, planned duration time is passed."

Environment

  • SAP Service Cloud v2
  • SAP Sales Cloud v2

Reproducing the Issue

  1. Go to Settings.
  2. Open Autoflow view.
  3. Click on the 3 dots and select rule logs.
  4. Select schedule rules query.
  5. Open the log for affected rule.
  6. You will see the error: Scheduled record invalidated,planned duration time is passed.

Cause

For example, you have set a schedule condition for 'Valid To' field in sales quote entity and the 'Valid To' date is in the past. Since the field value is in the past, you shall see "Scheduled record invalidated, planned duration time is passed" in the logs.

Resolution

The autoflow should be triggered for any new record that is created or an existing one that is updated manually, where the field date e.g. 'Valid To' is in the future. 

Keywords

Autoflow, Scheduled, Past, Duration, Time, Passed , KBA , CEC-CRM-AFL , Autoflow for SAP Sales/Service Cloud , How To

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0