SAP Knowledge Base Article - Public

3557210 - Business Partner Name in Language Adaptation

Symptom

When you change the businessPartnerService.name label in the Account entity, the same label is also updated in the Contact entity.

Environment

  • SAP Sales Cloud Version 2
  • SAP Sales and Service Cloud Version 2

Reproducing the Issue

  1. Open the User Menu.
  2. Select Settings.
  3. Navigate to All Settings.
  4. Under Administration Console, open Language Adaptation.
  5. Select the application Account - sap.crm.md.service.accountService.
  6. Choose the desired language.
  7. Search for businessPartnerService.name.
  8. Modify the Target Language Text for this label.
  9. Save the change.
  10. Reopen Language Adaptation.
  11. Select the application Contact - sap.crm.md.service.contactPersonService.
  12. Choose the same language.
  13. Search for businessPartnerService.name again.

Result: The Target Language Text reflects the change made in the Account entity.

Cause

The label businessPartnerService.name corresponds to the attribute formattedName, which is reused across multiple Business Partner (BP) services/entities, including Account and Contact. Any changes to this label in one service will reflect in all other services where the same attribute is used.

Resolution

This behavior is expected because the businessPartnerService.name label (default text: "name") is a shared resource used across all Business Partners services/entities.

Keywords

Account, Contact, Language Adaptation, Master Data, businessPartnerService.name, Sales Cloud Version 2, CNS , KBA , CEC-CRM-CON , Contact for SAP Sales/Service Cloud , CEC-CRM-TXA , Text Adaptation , CEC-CRM-ACC , Account for SAP Sales/Service Cloud , How To

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0