Symptom
- Campaign is executed to send an email to members of the Target group.
- When email is not opened for 'n' days(Here 'n' stands for 'n' no. of days), another email should be sent for all the members of Target group.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Sales Campaign Workcenter.
- Go to Target Groups Work center view.
- Click on '+' to create new Target Group.
- Add Employees and Contacts into the Target Group.
- Save Target Group, Note Target Group ID XXX.
- Go to Campaigns Work center view.
- Click on '+' to create new Campaign.
- Provide required details.
- Save and Open Campaign
- In Build tab, Click on Target group available under Target audience.
- In details, select the Target group XXX .
- Click on Send E-Mail action available under Actions.
- Select E-Mail template from available list.
- Click on Apply.
- Click on E-Mail Interaction available under Triggers.
- Click on Send E-Mail action available under Actions.
- Select E-Mail template from available list.
- Select any value from Events dropdown. Eg: Not opened.
- In 'For' field, Enter 'n' days. Here 'n' stands for email has to be sent after 'n' no. of days.
- Click on 'Apply' and 'Save'.
- Go to Details tab.
- Schedule Campaign to execute.
- Activate Campaign.
Cause
- In the Target group we can add Employees and Contacts.
- First mail will be sent to all the members, whereas Email interaction(remainder mail) will be sent to only Contacts.
- Since Marketing interactions are caught only to Contacts, Email interactions are sent to Contacts only.
Resolution
This is the current behavior for the scenario for the product.
Keywords
Target groups, Campaigns, Marketing, E-Mail, E-Mail Interactions, Not opened, Not replied. , KBA , LOD-CRM-MKT-CAM , Campaigns , Known Error
Product
SAP Cloud for Customer core applications all versions
SAP Knowledge Base Article - Public