Symptom
When creating a sales order from a solution order the flexible item category determination is not working as expected.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Configure the Flexible Item Category Determination.
- Open app Manage Solution Order -> [Create].
- Create a Sales Item.
- Select the Sales item and [Simulate Sales Order Creation].
- Check the Distribution status equals 'Success'.
- Open the sales order that can be found in the Transaction history.
- Note the Item Category that was determined is different to that specified in the Flexible Item Category Determination.
Cause
Flexible item category determination is initiated if the new sales order item has not already been assigned an item category, either through copying controls or manual entry. In the context of a solution order, the item category is predefined prior to the creation of the sales order. Consequently, flexible item category determination will not be activated in this scenario.
Resolution
The current iteration of the S/4HANA Public Cloud system does not encompass this particular business requirement. We encourage you to vote on relevant customer influence requests to signal to our development team the priorities for future releases. Alternatively, you may submit a new customer influence request. For more comprehensive information, please refer to the following Knowledge Base Article (KBA): 2963059.
Keywords
T184, ItemCat, Flex, BRF+, config, default, GOAL, IF_CRMS4_SOLO_ORC_PROCESS~MAINTAIN, FV45PF0F_FLEX_ITM_CAT_DETN, PROPOSE_DEFAULT_ITM_CAT, VA01, F4615 , KBA , SD-SLS-FLX , Sales Flexibility , SD-SLS-SO-2CL , Sales Orders (Public Cloud) , Problem
SAP Knowledge Base Article - Public