SAP Knowledge Base Article - Public

3557939 - Stop saving Employee Profile if the email address already exists in another Employee Profile

Symptom

Is it possible to stop saving employee profile if the email address already exists in another employee profile 

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Employees
  2. Create New with an e-mail which already exist in the system
  3. Observe: you are able to Save the new employee with the same e-mail address

Cause

Employee is a separate entity. However, for business configuration within your system, employees are also represented as business users in the system. Therefore, for every employee record that you create, a corresponding business user is automatically created in the system. Thus you can use same e-mail Address for multiples Employees. We do not have a validation in place to control the e-mail address field in C4C as standard. 

Resolution

This is an Expected System Bahavior. You may explore the possibility of using PDI to implement such validation.

Keywords

Block, Stop , E-mail, Employee, same e-mail, address , KBA , LOD-CRM-EMP , Employee , Problem

Product

SAP Cloud for Customer core applications 2411