SAP Knowledge Base Article - Public

3558086 - Sending emails via API with Technical User

Symptom

When sending an Email via API of Sales and Service Cloud V2 -   "/sap/c4c/api/v1/email-service/emails" using a Technical user, the following error is returned - "message": "No employee associated with User".

 

Environment

SAP Sales Cloud and SAP Service Cloud Version 2

Reproducing the Issue

  1. Using an API development platform e.g Insomnia.
  2. Attempt to send an Email with the following Post Request and body.
  3. Use a technical User for Authentication.
  4. The following error will occur: "message": "No employee associated with User"

https://xxxxxxxxxx.sap/sap/c4c/api/v1/email-service/emails


     "transmissionStatus": "SEND", 
     "channelId": "<Channel ID>", 
     "dataOrigin": "CHANNEL",
     "subject": "Test", 
     "body": "Test", 
     "direction": "INBOUND", 
     "from": "<channel email address>", 
     "toRecipients": ["<email address>"]
}

Cause

Technical User cannot be used for authentication for sending Emails using API.

Resolution

A Business user must be used for authentication when sending an Email via API.

Keywords

Email, API, Authentication, Business User, Technical User , KBA , CEC-CRM-EML , Emails for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0