SAP Knowledge Base Article - Public

3558192 - Supported Event Types in Signal API for Service Cloud Version 2

Symptom

As outlined in SAP Documentation, Signal Service API aims to integrate external systems via REST API call and provide relevant signals to Customer Insights.

Customer Insights service exposes APIs to receive signals from external systems and you can call the API from any external system that provides signals.

Within the available Attributes of Signal Service API you want to know in particular for Event Type, what are the supported event types and/or its usability.

Reproducing the Issue

Attribute: eventType  

Description: Generic Signals support most event types.

Cause

It’s a POST request, to essentially push any third-party signals to Sales and Service Cloud Version 2.

Resolution

The eventType attribute in signal payload which is currently not used.

It was introduced with the idea that in the future when we have integration with AutoFlow, this eventType value can be used to trigger some downstream processing.

See Also

Reference: https://help.sap.com/docs/CX_NG_SVC/56436b4e8fa84dc8b4408c7795a012c4/9b80de6187d845139d6f882292a3dfc6.html

Keywords

Signal Service API;eventType; cns , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , Bug Filed

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0