SAP Knowledge Base Article - Public

3558413 - Duplicate Invoice ID's created by the system

Symptom

Duplicate Invoice ID's are being generated by the system in the beginning of each year.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to Customer Invoice work center
  2. Select Invoice Documents view
  3. In the drop-down, select All Invoice Documents
  4. Search for the Invoice ID ABC (Where ABC stands for the Invoice ID)

You will be able to see two invoice ID's with the same ID e.g ABC.

Cause

  • Usually, this issue happens when a new rule is created in the system in the beginning of the year or if the user creates the first document of the year using webservice/run.
  • In some cases the system creates duplicate invoices as the system takes time to assign the first number to the first invoice. At the same time, if another invoice is created e.g. manually, the system picks the same number.
  • This is the current system behaviour and it cannot be changed.

Resolution

  • As a workaround, cancel one of the duplicated invoices and create a new one.
  • To avoid this issue, create the first invoice of the year manually.

Keywords

Duplicate, document, incorrect, invoice, first invoice, not expected. , KBA , AP-CI-CI-GLO , Cross-Country Extensions , Problem

Product

SAP Business ByDesign all versions