Symptom
Dunning letter is not sent due to below error:
- No output possible for output item '1' due to inconsistencies.
- Item '1': no email recipient has been maintained.
Environment
SAP S/4 HANA Cloud Public Edition
Reproducing the Issue
- Open the app Create Dunning Notices
- Provide the parameters.
- Execute the dunning run.
- Check the log.
Cause
- If the email address is not maintained in the business partner's master data or Output Parameter Determination app, the dunning letter cannot be sent.
Resolution
- Refer to section 4.2.5 Determining Email Recipients in the documentation Setting Up Output Management (1LQ)
- The system will send the dunning letter to the email address maintained in the business partner master data, which is the business partner's master data. If the email is not maintained in this field, it needs to be maintained in the Output Parameter Determination app.
- In the Output Parameter Determination app, choose 'Show Rules For - Dunning' and 'Determination Step - Email Recipient'.
- To resend an email due to an absence of email address in the business partner master data, causing a failure in sending the email, here are the steps to follow:
- Open the application Create Dunning Notices.
- Enter the Run Date and ID.
- Navigate to Menu -> Go To -> Output or Press Shift + F12.
- If the status is 'In Preparation', select one of the Output listed.
- Click on Display Details.
- If the email address is not mentioned, add it here.
- Save and go back.
- Click on Send Output.
See Also
Refer to KBA 0002870653 - Configure Dunning and Email Outputs for SAP Fiori apps F2435: My Dunning and F2328: Display Dunning History.
Keywords
Output Parameter Determination app, FDT0 OPD_APOC_SYSTEM object, error message, TO128, Dunning, Email Outputs, SAP Fiori apps, F2435, F2328, Display Dunning History, business partner master data. , KBA , FI-AR-AR-C-2CL , Dunning/Interest (Public Cloud) , Problem
Product
SAP S/4HANA Cloud Public Edition all versions
SAP Knowledge Base Article - Public