Symptom
You are performing an initial data load in Sales and Service Cloud Version 2 (CNS) where you plan to transfer a large volume of data to Sales & Service Cloud Version 2.
Before concluding the load activity, you might realize that several messages start running into Fail status in CPI with the Error Code: 429
Environment
Sales Cloud Version 2
Service Cloud Version 2
Reproducing the Issue
Send an initial data load from an on-premise system to Sales & Service Cloud V2.
- Open the URL of your CPI URL system.
- Go to Monitor view
- Under the Monitor Message Processing, open All Artifacts tile
You will find the respective Artifact Name (iflow) on the Failed state with the Error Details: Status Code: 429
Note: 429 Error Code means Too Many Request
Cause
You have exceeded the rate limits of API Calls for your tenant within 24 hours; This article aims to elucidate the process you have to follow while performing initial data load from SAP S4HANA or SAP S4HANA Cloud or SAP ERP into Sales & Service Cloud v2 and when it over exceeds the limit of API Calls(services part of Communication configuration / data-connector enabled) outlined in the supplement document, part of an agreement for SAP Cloud Sales and Services Version 2.
As per the SAP Commercial Model, you can only send 150.000 messages, plus an additional 1,500 messages per licensed User, within the 24-hour time frame, from S/4 to Sales and Service Cloud V2.
SAP Sales Cloud and SAP Service Cloud Version 2 Supplemental Terms and Conditions outline the following:
"The total number of API and event calls related to the Cloud Service per 24-hour period is limited to 150,000 plus an additional 1,500 per licensed User. This includes all API calls for the Cloud Service except the standard Cloud Service User Interface. Data import and exports can only be done one at a time, and not in batches. Each import or export cannot exceed 50,000 records per block."
Please Note: For Production Tenants, the number of allowed calls is calculated as described above; whereas for Test Tenants the limit is 30000 per day.
Resolution
For the initial load in a standard integration scenario, SAP can temporarily increase the quota for a limited number of days.
To request this, you should contact SAP Support either:
- Before triggering the initial load, or
- Upon encountering a 429 error in SAP,
so that SAP can lift the quota restriction for a defined period.
Please submit a new case to the component CEC-CRM-CO-OPS (Product Function: Cloud Operations), and include the following details:
- Sales or Service Cloud Version 2 URL
- Estimated number of requests expected to be processed every 24 hours
- Requested time frame during which the rate limit should be increased
See Also
SAP intends to launch either a Data Source or a User Interface that displays API requests for each entity.
Keywords
initial load; Large Data Load, Bulk Processing, Best Practices, Initial Load from ERP to CNS, Initial Load from S4HANA to CNS;V2; Supplement;Sales Cloud Version 2; Service Cloud Version 2;429; too many request , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , CEC-CRM-IFR-AMB , Ambassador for SAP Sales/Service Cloud , CEC-CRM-CO-OPS , Operations , Known Error
SAP Knowledge Base Article - Public