Symptom
- What is the maximum number of digits that you can set on the Global footer of the notification available in Email Services?
- After adding a global footer for email templates in Email Services, it disappears once the Email Services is exited and it doesn't appear in the emails sent.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Navigate to Email Services > EMail Template.
- Select any Email Template
- Configure the email as per your requirement
- In Step 3, add a footer.
- After adding, exit the email services.
- The footer that was just added disappeared or did not reflect on the email sent.
Cause
- Characters entered has exceeded the limit configured for the footer.
Resolution
By default the footer is configured with 255 maximum characters, but it can be extended from the object definition upto 4000 characters.
Steps:
- Navigate to Configure Object Definition
- Select the object 'EmailSettings'
- Take Action > Make Correction
- Under the footer field, change the character limit to 4000
- Save it.
After the above steps, ensure to execute an Object Definition cache.
- Check and run the MDF Object Definition to DB Sync Job (Provisioning)
- Run the MDF Cache Tool (Provisioning)
- Run the Metadata OData API (Instance UI)
Once all of the above steps done, try to add the footer again. It should be saved successfully.
See Also
Keywords
Global Footer, Footer, Email Settings, Character Limit, Email Services, Email Template, EmailSettings, Configure Object Definition, Character, Email, OBX, Onboarding, ONB2 , KBA , LOD-SF-OBX-EML , Notifications , Problem
Product
SAP SuccessFactors Onboarding all versions