SAP Knowledge Base Article - Public

3560013 - Attachments added in My Inbox app are not reflecting in the Sales Order post approval in SAP S/4HANA Cloud Public Edition

Symptom

  • After the creation and approval of a sales order, the attachment added in the My Inbox app during the approval process is not visible in the sales order (VA02) and Manage Sales Order app.
  • If the same order is sent for another round of approval, the attachment is still not visible in the My Inbox app.

Environment

  • Make-to-order, assembly order (Public Cloud)
  • SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. A sales order is created.
  2. The sales order is sent for approval.
  3. Within the My Inbox app, the sales order is selected.
  4. An attachment is added to the sales order by the approver.
  5. Once the document is approved, it is noticed that this attachment is not present within VA02 for the Sales Order.
  6. If the Sales Order is sent for further approval, the attachment is not visible.

Cause

Expected system behaviour.

Resolution

  • The attachments added by the approver during the approval process are stored only in the work item from the current step in the approval process.
  • Such attachments cannot be found in the documents as per system design.

Keywords

SAP S/4HANA Cloud Public Edition, Sales Order Management and Processing, Sales order, Approval, Attachment, My Inbox app, VA02, Manage Sales Order app, SAP S/4HANA Cloud Public Edition, sales order., sale, order, attach, file, document, approver attachment, PR requestor, view attachment, approval process, work item, investigation, attachment missing, attachment is missing. , KBA , SD-SLS-SO-MO-2CL , Make-to-order, assembly order (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions