Symptom
How to analyse paired time event imports being blocked
Environment
- Employee Central Core
- Time Tracking
Reproducing the Issue
- Create a time event pair within the timesheet UI
- Upon refreshing, no time sheet entry is created and you receive an import error
Cause
The cause of these errors is explained within the message received and can have a multitude of reasons
Resolution
You should endeavour to resolve all import issues to ensure an older error is not blocking the process
- Take note of all import alerts highlighted within the Time Alert tab in Administer Time
- Ensure that all issues flagged there are resolved accordingly
- Rerun import
- If some issues persist, you can delete time events for which not time sheet entry exists
- Rerun import
- Any external codes that are still highlighted in the alerts for which time events are already cleared (CICO-*) can be cleared manually.
Delete the external time data using the delete flag in manage data for those external codes still showing as in error in the alerts. See KBA 2856879 - Recalculate timesheet and Rerun import
- If afterwards some alerts are still flagged and you are confident the related events and external time data entries were removed
you can delete the time management alert object containing the alerts in question to clear these as they can be stuck due to inconsistencies in the linking.
This last step you should only be done once all issues flagged in the object are addressed but the error remains
As always, it is advised to run this in a preview instance and for a single test employee first.
The main thing to keep in mind is that old import alerts can cause a block for future runs for the same
employee and that the majority of cases can be resolved by clearing and recreating time events
Keywords
inconsistency, alert, time event , KBA , LOD-SF-TTR-CIO , Clock In/ Clock Out , How To