Symptom
- Unable to save ratings in Interview Central post Talent Intelligent Hub (TIH) Migration. When trying to save it, nothing happens.
- In the browser console, there is a 500 Internal Server Error at interview assessment.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors Recruiting Management
- SAP SuccessFactors HCM Suite
Reproducing the Issue
Interview Central:
- Go to Recruiting > Interview Central
- Click Rate Now
- Provide ratings
- Click Save or I'm done
- Nothing happens
Troubleshooting - Browser Console:
- Right-click on the interview assessment page and select 'Inspect'.
- It opens the browser developer tool.
- Go to the 'Console' tab.
- Try to save the ratings in Interview Central.
- A 500 internal server error is displayed - https://<Application Url>/rest/recruiting/interview/v1/assessments 500 (Internal Server Error)
Cause
- The Job Profile Builder migration (JDM to JPB migration) is not completed.
- English Debug translations in TIH attributes prevent the competencies or skills from syncing correctly. (For SAP Support: refer to sample logs in internal memo)
Resolution
Please complete Job Profile Builder migration. If any error is encountered with the Job Profile Builder migration, please address the error first.
To prevent attribute sync issues, ensure that there are no English Debug translations present in TIH attributes.
To verify if Job Profile Builder migration is completed, follow these steps:
- Go to Admin Center > Check Tool > System Health tab.
- In the 'Area' dropdown, select 'Job Profile Builder'.
- Click Go.
- From the result, select 'Job Profile Builder migration successful. (JPBEnabledAndMigrationCheck)'.
- Run checks.
Address errors with the Job Profile Builder migration:
For any assistance with the Job Profile Builder migration, raise a Support case with the component LOD-SF-TIH-JPB (Job Profile Builder).
- Run the Check Tool for all prerequisites as described in the 'Data Validation for Talent Intelligence Hub in Check Tool' section of KBA 3328015 - Migrating Job Profile Builder Data to Talent Intelligence Hub.
- Address all errors detected by the Check Tool.
- Complete the Job Profile Builder migration.
Remove English Debug translations from TIH:
Please check if any of competencies or skills added to the job requisition have English Debug translations in TIH. Please note that in TIH English debug locale is not supported and all the translations of this locale must be removed. For more information, see KBA 3638462 - WSM IDs are created but JPB reference is not present - Talent Intelligence Hub.
- Navigate to Admin Center > Manage Talent Intelligence Hub.
- Select the Attributes tab.
- Search for the attribute with the Competency type.
- Select the competency.
- Select Edit.
- Select the globe icon in the upper right-hand corner to open translations.
- Select English (DEBUG).
- Remove all text from the Name and Description fields.
- Save changes.
If both Job Profile Builder migration and Talent Intelligent Hub migration are successfully completed:
After the Job Profile Builder migration is completed, the system will generate a mapping entry for each competency. Users will be able to save ratings in Interview Central.
If the issue persists, raise a Support case with the component LOD-SF-RCM-JOB (Recruiting Management) and provide the KBA number 3536526 - Recruiting Issues Post JDM/JBP/TIH Migrations - Recruiting Management.
It is recommend to include the following details when raising a Support case.
- Company ID
- Support access
- Proxy as (Interviewer)
- Job Req ID
- Candidate name
- Affected competency names (if the issue only occurs to certain competencies)
- Steps to reproduce the issue
- Support troubleshooting steps:
1. In Interview Central, obtain the affected competency names.
2. In Manage Talent Intelligence Hub, obtain the 'wsmId' for the competency name.
- Go to Manage Talent Intelligence Hub.
- Search by the competency name.
- Check the ID column (Click the Gear button to add this column if it is hidden). *The ID represents the wsmId.
3. In Manage Data > JdmJpbMappingEntity, verify if the mapping entry is created.
- Go to Manage Data
- In the 1st dropdown, select 'JdmJpbMappingEntity'
- In the 2nd dropdown, type the ID obtained at the previous step.
- Verify if there is a match for the wsmId. *The mapping entry may not exist if there is an issue.
See Also
Talent Intelligent Hub Migration Issues:
- SAP SuccessFactors Recruiting Administration Guide > SAP SuccessFactors Recruiting Integration with Talent Intelligence Hub
- KBA 3536526 - Recruiting Issues Post JDM/JBP/TIH Migrations - Recruiting Management
- KBA 3328015 - Migrating Job Profile Builder Data to Talent Intelligence Hub
- KBA 3361064 - Error with Job Profile Builder enablement status (Check ID: JPBNotMigratedMandatoryPreCheck or JPBEnabledAndMigrationCheck) - Talent Intelligence Hub
- KBA 3361027 - Error with migration of competencies in job requisitions (Check ID: UseJobProfilesInReqCheck) - Talent Intelligence Hub
- KBA 3638462 - WSM IDs are created but JPB reference is not present - Talent Intelligence Hub
Permission Issues:
Keywords
JDM, JPB, TIH, RCM, migration, Job Profile Builder, Job Description Manager, Talent Intelligence Hub, Recruiting, Job Requisition, Check Tool, Competency, Interview Central, Rating, NumberFormatException, Cannot parse null string , KBA , LOD-SF-RCM-IVW , Interview Central, Interviews, Scheduling etc , LOD-SF-TIH-JPB , Job Profile Builder , Problem
SAP Knowledge Base Article - Public