Symptom
- If we open a quote in CPQ with a status where the 'Add Item' action is not enabled in the workflow, and then open Setup in a new browser tab, navigate to any Product, go to its Layout tab, and click on Configuration Preview, an error appears stating: "Add item action is not available in this status."
- However, you have intentionally not set the 'Add Item' action for the user in the workflow for the specified status, as per the requirement.
- But if we go to Load Quotes page, and not to any particular quote, and then click on Configuration Preview, we see no such error.
- You would like to know why the Configuration Preview button under Setup is not independent of any quote which is open in another tab.
Environment
SAP SALES CLOUD CPQ
Reproducing the Issue
- Login to CPQ and go to Load Quotes page
- Open Setup in another browser tab
- Go to Products Catalog
- Go to Products
- Select a Product
- Go to Layout tab
- Click on Configuration Preview
- We are able to view the configurator
- Now open a CPQ quote
- Open Setup in another browser tab
- Go to Products Catalog
- Go to Products
- Select a Product
- Go to Layout tab
- Click on Configuration Preview
- We get error.
Cause
'Add Item' action must be enabled in the workflow for the specified status to avoid this error.
Otherwise, this behavior is expected, as using CPQ in multiple tabs is not supported. This is because, when navigating to Setup, the quote context remains active since Setup is stateless and does not logout the user. Loading a new quote clears the previous context and updates to the current quote tab.
Resolution
Please avoid opening CPQ instances in multiple browser tabs.
Keywords
Configuration Preview, Layout, browser, multiple tabs, 'Add Item' action, workflow, status, load quotes, quote, setup , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem