Symptom
- Business rule with Lookup function evaluating Payment Information data (IBAN, Account Number...) even after withdrawing/rejecting a workflow with payment information MDF object with Pending data = Yes.
- If employee submits a request to update the payment information including IBAN or Account Number and workflow gets rejected or sent back, business rule that checks if an IBAN/Account Number already exists in the system gets triggered, even if it is a new IBAN/Account Number.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors HCM Suite
- SAP SuccessFactors Employee Central
Reproducing the Issue
- Go to the Payment Information section and update the IBAN number with an effective date in the future;
- Submit the request;
- Proxy as the approver and send the workflow back to the employee or reject it;
- As the employee, update and resubmit the request.
- Business rule that checks if the IBAN number already exists in the system gets triggered.
Cause
Lookup condition on Business Rule is based on "Payment Information Detail" which is not workflow-enabled and consequently causes that inactive and pending records are included on the business evaluation.
Resolution
To exclude pending records from the lookup, it is necessary to define the lookup based on an workflow-enabled object, i.e. on object "Payment Information".
See Also
2476269 - Payment Information: Data is saved before approving or rejecting the workflow (PaymentInformationV3PendingData)
Keywords
INC7113609, lookup, payment information, payment information detail, workflow, rejected, declined, withdraw, IBAN, account number, business rule, rule, pending data, duplicate , KBA , LOD-SF-EC-PAY , Payment Information (Bank Information) , Known Error