Symptom
You would like to configure the "Valid To" date in Sales Quote.
Environment
- SAP Sales Cloud and SAP Service Cloud V2
- SAP Sales Cloud V2
Reproducing the Issue
- Go to Sales Quotes view.
- Click "+" to create a Sales Quote.
- We can see that the Valid To date is automatically set to one day after the creation date.
Cause
This is as per system design. However, there is a workaround that can be achieved via Custom Logic.
Resolution
It is possible to create a Determination where you can specify your scenario and how you want to set the validity end date.
This can be done with a simple expression such as:
{validityPeriod/endDate} = ( $CURRENT_DATE_IN_UTC() + 'P30D' ) .
Here:
- "validityPeriod/endDate" is the field where they want to upload the value.
- "$CURRENT_DATE_IN_UTC()" is an in-built function that gives us the current date.
- "P30D" is the way we specify how many days we want to use for any operation (P- period and D- day).
This is already some thing that we support and you can directly achieve this by creating a Determination.
Keywords
Valid To , Sales Quote , Date , Automatically , Period , Custom , Validation , KBA , CEC-CRM-CQP , Sales Quote for SAP Sales/Service Cloud , Problem