Symptom
Social Insurance Number (SIN) value is empty in Canada compliance forms (e.g. TD1 Personal Tax Credits Return).
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Login as candidate
- Open compliance task tile
- Open Canada compliance forms (e.g. TD1 Personal Tax Credits Return)
- Social Insurance Number field is empty
Cause
Code is inconsistent in Country Specific Succession Data model.
Steps to check:
[1] Mapping configuration in compliance form for Social Insurance Number (SIN) field:
- Go to Manage Data > Compliance Form > form code (e.g. CA_TD1_2024_V2)
- metadataForFormFields > find fieldName "Social Insurance Number" by ctrl+F > click on "Details"
- See mapping "ecFieldMeta":
{"entity":"nationalIdCard","entityPath":"personNav/nationalIdNav","fieldPath":"","fieldType":"","field":"nationalId","filters":{"country":"CAN","cardType":"sin"}}
[2] Configuration of Country/Region Specific Succession Data Model:
- Go to provisioning > Import/Export Country/Region Specific XML for Succession Data Model
- Export file > check configuration:
<country id="CAN">
<format-group id="national-id">
<format id="SIN">
<instruction>Social Insurance Number</instruction>
<instruction xml:lang="en-GB">Social Insurance Number</instruction>
......
<display-format>NNN-NNN-NNN</display-format>
<reg-ex>[\d]\{3\}-[\d]\{3\}-[\d]\{3\}</reg-ex>
</format>
Resolution
- Changing the format id code from "SIN" to "sin" in the Country/Region Specific Succession Data Model
- Re-upload the data model XML file in provisioning
- Restart onboarding for candidate and check if SIN value can be populated
Keywords
SAP, SuccessFactors, Onboarding, Social Insurance Number, SIN, Canada, compliance , KBA , LOD-SF-OBX-FRM , Compliance 2.0 Country Forms (except i9&EV) , Problem