SAP Knowledge Base Article - Public

3560879 - Approval Process for Customer Invoice is not working as expected

Symptom

The Approval Task of the Approval process for Customer Invoices is not being assigned to the expected Reporting Line Unit Manager after the Responsible Employee revised the Customer Invoice and sends the Invoice for approval again.

Environment

SAP Business ByDesign

Reproducing the Issue

For this scenario, the following employees are involved: 

  • Employee: 1
  • Employee: 2
  • Employee: 3

 

Where 1, 2 and 3 represents the respective Employee ID involved in the scenario.

  • For employee 1 the Reporting Line Manager is 2
  • For employee 2 the Reporting Line Manager is 3

 

  1. Employee 1 creates the Invoice and sends it for approval.
  2. Employee 2 reviews the details and sends the invoice back for revision.
  3. Employee 1 reviews the details requested by Employee 2 and sends it back for approval.
  4. Employee 3 receives the task, but you expect that employee 2 receives the task again.

Cause

For this particular scenario, the Work Distribution for the Approval Process for Invoices, is set as Reporting Line Unit Manager.

 

The Employee 1 creates the Invoice and sends it for approval. The Employee 2 reviews the data and sends the document back for revision. Employee 1 executes the change suggested by Employee 2 and executes the change in a text field such as Customer Information, Internal Note or Approval Note.

 

When the invoice is sent back for revision and the change is done to any text related fields such as Customer Information, Internal Note and Approval Note on either the General tab or the Items tab, the approval task goes to the next level of approval, which is in this case, Employee 3.

This occurs because the changes are executed on a dependent object (TEXT COLLECTION) and on the Business Object (Customer Invoice).

As per the system logic, the system captures the change executed by Employee 2 (in step 2) as the last change person and the approval task goes to Employee 3.

 

However, if the Employee 2 sends the document back for revision and the Employee 1 executes the change on fields such as "Invoice Date" or "Price List", the change is logged as a change on Customer Invoice Business Object and the approval task goes to Employee 2 which is the expected employee to receive the approval.

Resolution

This is the current system behaviour.

Keywords

Approval Process, not working, does not trigger, incorrect, invalid. , KBA , SRD-CRM-INV , Customer Invoicing , Problem

Product

SAP Business ByDesign all versions