SAP Knowledge Base Article - Public

3560900 - Issue When Modifying the Trigger in an Existing Campaign

Symptom

You have created new triggers in the Configuration App, and want to use them in an existing Campaign. However, the new triggers are not available for selection.

Environment

SAP Marketing Cloud Edition

Reproducing the Issue

  1. Log on to the SAP Marketing Cloud Tenant and you create new triggers in the Configuration App.
  2. Open the Campaigns App.
  3. Select an existing triggered based campaign.
  4. You have configured new triggers within the Configuration App and intend to implement them in an existing Campaign. However, these new triggers are currently unavailable for selection

 

 

Cause

This is standard system design and behaviour because newly created Triggers are only available to new campaigns. 

Resolution

  • When a campaign is created, it initializes the triggers that are available in the system at that time. Any interaction types introduced after the campaign's creation will not be available for selection.
  • Additionally, copies of this campaign will also not include the new interaction types. 

Keywords

KBA , CEC-MKT-CPG , Campaign , CEC-MKT-CPG-UI , Campaign UI , Problem

Product

SAP S/4HANA Cloud Public Edition all versions