Symptom
A custom transaction type created is not appearing in the "Manage Incoming Payment File" app under the "Format Selection" screen.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Navigate to "Manage Incoming Payment Files" App.
- Click "Import".
- Click "Upload".
- Select the File (Bank Statement) from the Desktop/System and Click "Process".
- Click "GO".
- The new transaction type is not shown in the "Status".
Cause
The system is not recognizing the newly created transaction type because it is not assigned to the respective bank account.
Resolution
- Assign the defined transaction type to the respective bank account.
- Upload the electronic bank statement files.
- When maintaining the transaction type in the bank account, it does not matter which format is selected in the "Manage Incoming Payment Files" App.
- The entries in the "Manage Incoming Payment Files" App lead all to the format but they have different default values for the transaction type.
- This default transaction type is only used when it is not used in the bank account.
- Enter the created transaction type in the relevant house bank accounts.
- Select any format in the "Manage Incoming Payment Files" App.
- The expected transaction type will be used for the interpretation.
Keywords
MT940, Transaction Type, Manage Incoming Payment Files App, Format Selection. , KBA , FI-FIO-AP-2CL , Fiori UI for Accounts Payable (Public Cloud) , Problem
Product
SAP S/4HANA Cloud Public Edition all versions