SAP Knowledge Base Article - Public

3561584 - Service Agents Blocked via Information Lifecycle Management are Visible in the Organizational Unit

Symptom

Service agents blocked via Information Lifecycle Management (ILM) are visible under employees in the Organizational Management structure.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to Information Lifecycle Management workcenter
  2. Go to Business Partners view
  3. Search for the required Service Agent
  4. Notice the Status is Obsolete
  5. Now, navigate to Organizational Management workcenter
  6. Go to Org Structure view
  7. Search for relevant Org Unit ID
  8. Observe that the blocked service agent is visible under Employees tab.

Cause

Blocking a service agent via ILM only prevents the agent from being used in the future. However, the assignment of this service agent from the Organizational Unit is not removed.

Resolution

Block any business partner from being used, for instance in case of a lawsuit due to which you no longer want to continue the business relation. Until you are entitled to delete all related information, you can simply block the usage. This means only blocking the service agent from being used in the future but the assignment of this service agent from the Org Unit will not be removed. In this case, the service agent should be manually removed by using the End Assignment from the Org Unit as per the below steps:

  1. Navigate to the Organizational Management work center.
  2. Select Edit
  3. Highlight the Org Unit where the Service Agent belongs to
  4. Go to the Employees tab
  5. Highlight the Service Agent
  6. Select End Employee Assignment
  7. Save and activate the Org Unit

Keywords

Information Lifecycle Management, ILM, Service Agents, Organizational Management, Org structure, block usage, master data, supplier base, visibility, assignment, end assignment. , KBA , AP-RC-ILM , ByD,C4C,Travel: Information Lifecycle Management , Problem

Product

SAP Business ByDesign all versions