SAP Knowledge Base Article - Public

3561749 - Custom order does not work in Server-side Outlook Add-in

Symptom

  • List items are sorted from ascending to descending in C4C, but this sort order is not reflected in the Outlook add-in for server-side integration.
  • The issue persists even after sorting the field in the C4C system.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Start adaptation mode.
  2. Configure a custom order for the list field "KUT_XYZ". (KUT_XYZ represents the field's name)
  3. End adaptation mode.
  4. You can see the field's values are sorted as expected in the C4C system.
  5. Now check the sort order of the field "KUT_XYZ" in the Outlook add-in for server-side integration.
  6. You will see the field's values are not sorted as expected.

Cause

After enabling the sort functionality for the KUT field, the things below will happen when editing the field in C4C system:

  1. The backend server returns the original list to the C4C frontend.
  2. C4C frontend sorts the original list according to your settings.
  3. The UI screen displays the sorted items.

However, when you edit the field in the Outlook Add-in, the things below are happening:

  1. The backend server returns the original list to the Outlook Add-in.
  2. The Add-in displays the original list of items.

The code list is not sorted in the database, and the server-side outlook add-in directly displays the data based on the raw data. Thus, the list displayed in the add-in is unsorted.

Resolution

The custom order or sort functionality is only applied within the C4C system and will not be reflected in the Outlook add-in for server-side integration. This is a system behavior that can not be changed. 

However, if you are setting the custom order for a KUT field, it's possible to sort the field's values in both C4C system and Outlook Add-in by the steps below.

  1. Start adaptation.
  2. Download the KUT field's codes and values to Excel.
  3. Sort its value in Excel.
  4. Re-upload the sorted codes and values to the C4C system.
  5. End adaptation.
  6. The new order will now be reflected in both the C4C system and Outlook Add-in.

See Also

3413684 - Appointment Categories Are Sorted Alphabetically In C4C But Not In Outlook Add-in.

Keywords

Sort Order, Custom Order, Outlook Add-in, Adaptation , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , AP-RC-UIF-FLX , Page Layout & Key User Configuration , Problem

Product

SAP Cloud for Customer core applications all versions