Symptom
- An application error appears when trying to approve an Inactive User purge.
- The purge response would be accompanied by "Error: There is no country specified for this user or user's country is not DRM enabled"
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors HCM
Reproducing the Issue
- Go to Data Retention Management
- Create New Purge Request
- DRTM Master Data Purge
- Upload a list of inactive users only (by User ID or Assignment ID
- Add approvers:
- Launch
- Proxy as approver
- Approve request
- Go to purge request monitor
- Export purge response
- Result: Error appears in the log:
"Error: There is no country specified for this user or user's country is not DRM enabled."
Cause
This is caused by a configuration issue.
Resolution
Important Notes:
-
The legacy purge function may not meet all of your data protection and privacy requirements. It doesn’t cover data across the full HCM Suite and doesn’t enable you to configure data retention times. Please check this section of the Admin Guide to view the limitations of Legacy Data Purge Function.
-
We encourage all customers to stop using the legacy purge function and start using data retention time management (DRTM) instead ( See guide: You have enabled the DRTM Master Data object in Upgrade Center.). To get started using this and other data protection and privacy features, refer to the Data Protection and Privacy guide.
Customer must complete below configuration
- Enable feature : DRTM Master Data Via Upgrade Center
Important:
Please upgrade this feature to configure retention times for legal entity and countries.
See guide: You have enabled the DRTM Master Data object in Upgrade Center.
Try user purge after upgrade and configuring retention times.
- Another option is to try to purge with ignore retention time.
For Error: "There is no country based data retention configured for the selected purge criteria"
Please configure retention time for the country under "Manage Data >> DRTM Master Data"
FAQ - Additional Information
Q) Where can I get information on this from the Guide?
A) Guide: Implementing and Managing Data Protection and Privacy under >
Chapter:
- You have enabled the DRTM Master Data object in Upgrade Center.
- Termination Date Between Employee Central and Standard User Fields
- Adding the CompanyExitDate Field to the User Record
Q) Is it possible to re-activate purged users which have been soft purged using the legacy purge inactive user Data Retention Management Purge or Data Retention Time Management Purge?
A) Yes, A soft purge is when the user is still existing at the Database level. View : 2392094 - Re-activate a Purged User Via employee Import Feature
Q) Is it possible to purge user separately in LMS only?
A) No, it's not supported.
Q) How soft purge user can be re-activated?
A) 2392094 - Re-activate a Purged User Via Employee Import Feature.
See Also
- 2545988 - How to Purge/Delete users in SuccessFactors
- 3375924 - How To check User Status Via Data inspector
- 2584658 - How to Check if a User is an EC User using the Integration Center - isECRecord Boolean
- 3058601 - How To Check Soft or Permanent Purge User
- 2615360 - Data Protection and Privacy - Data Retention Time Management (DRTM) - Master Data Purge for Inactive Users
Keywords
DRTM, Error: There is no country specified for this user or user's country is not DRM enabled, purge, solf purge, purge users, inactivate users, data retention management, DRM, username, terminate, userid, LMS, Enable Purge Inactive User request type , Incident, INC10742232, DRTM Master Data, Upgrade Center , KBA , LOD-SF-EC-DRM , Data Retention Management - (DRM & DRTM) EC Data Only , LOD-SF-PLT-DRM , Data Retention Management , Problem