SAP Knowledge Base Article - Public

3562724 - Extension Field in Registered Product Failed to Be Added into Standard Web Service QueryRegisteredProductIn

Symptom

Extension field ABC created in business context "Registered Product - General Information" has been added to service QueryRegisteredProductIn, but it cannot be found in the WSDL file of this service and it is not in the response of this service.

ABC represents extension field name.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Navigate to work center Service Entitlements, access view Registered Products.
  2. Select a registered product, click Edit.
  3. Select tab General.
  4. Click the Profile on the upper right corner, select Key user settings - Start Adaptation Mode. Click OK in the pop-up window.
  5. Right click on section Registered Product, select + Extension Fields in the pop-up window.
  6. Under business context "Registered Product - General Information", select extension field ABC, click Show Further Usage.
  7. Select tab Services, it has been added to Service QueryRegisteredProductIn operation FindByElements.
  8. However, this extension field cannot be found in the WSDL file of this service. Use this service to query registered product, in the response there is no content about this extension field.

Cause

Due to technical limitation, extension field in business context "Registered Product - General Information" cannot be added into service QueryRegisteredProductIn. Though it seems added to this service in adaptation mode, actually it is not added. 

Resolution

This is a current limitation.

As workaround, try to use BO IndividualProduct in OData service to fulfill your requirement.

Keywords

Extension Field, Adaptation Mode, Registered Product, General Information, Service, QueryRegisteredProductIn , KBA , AP-IBA-IPO , Installation Point , Problem

Product

SAP Business ByDesign all versions