SAP Knowledge Base Article - Public

3563056 - How to Update Contact Accounts Using Data Import & Export Tool

Symptom

When performing the Import > Update to update Accounts related to Contacts, the import is successful but no changes occurs in the Contact itself.

Environment

  • SAP Sales Cloud V2
  • SAP Service Cloud V2

Reproducing the Issue

  1. Go to the Settings > All Settings
  2. Open Data Import and Export
  3. Select Export  > Choose the Contact Entity
  4. In the file exported, update the Account information
  5. Go back to the system and select Import > Update > Contact > Upload the updated file

Result: The import is successful, but no changes occurred in the Contact itself.

Cause

In the Contact entity in UI, it possible to see that there is no option to update the account associated to it. There is only the option to delete or add a new one. 
This is a current limitation of the system. The development team is already working to add this functionality, but there is no date for the release yet. 

The Data Impex has always the same behavior of the UI. As it's not possible to edit the Account information of the Contact in the UI, it's also not possible to do it in the Data Impex. 
However, it's possible to delete the existing account, and then add a new one. 

Resolution

Please check the steps below and follow accordingly: 

TO DELETE

  1. Go to the Data Impex
  2. Click on "Export"
  3. Select "Contact" > "Complete Entity" > Apply the required filters > Export
    (for better understanding of the steps, it is recommended to export only one file in the first time)
  4. In the file exported, extract the .zip
  5. Open the file "Contact_Is_contact_person_for_" and copy the value of the field "Technical ID"  and of the field "Parent_Technical_Key"
  6. In this same file, you will add a new column "to_be_deleted" and will set the value as "TRUE"
  7. Save this file, zip all the files again and go back to the system
  8. Import > Update > Contact > Complete Entity > Import
    > This will delete the account previous inserted

TO ADD NEW

  1. Go to the Data Impex
  2. Click on "Export"
  3. Select "Contact" > "Complete Entity" > Select the same entry as in the Delete phase > Export
  4. In the file exported, extract the .zip
  5. Open the file "Contact_Is_contact_person_for_"
    > In the field: "Technical ID" paste the value copied in the Delete phase
    > In the field: "Parent_Technical_Key" paste the value copied in the Delete phase
    In the field: "Account Technical ID" insert the UUID of the correct account that you want to relate to the contact
  6. Save this file, zip all the files again and go back to the system
  7. Import > Update > Contact > Complete Entity > Import

By following these steps, the wrong entry will be deleted and the new one will be added.

Keywords

Contacts, Import, Update, Account, UUID, Technical ID, Data Impex, Export, Delete, Create New , KBA , CEC-CRM-IMX , Data Import/Export for SAP Sales/Service Cloud , CEC-CRM-CON , Contact for SAP Sales/Service Cloud , How To

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0