SAP Knowledge Base Article - Public

3563126 - The value of custom field is not getting pulled from customer project to related sales order table

Symptom

When customer maintain a custom field in app "Plan Customer Project" and save,
the value of the custom field is updated to related Sales Order - Services,
but it's not flowing into the Sales Order table VBAK.
This will cause the custom field is not updated in the sequent Billing Document Request.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. In app "Custom Logic", you have defined extension fields for the business context Engagement project.
    and implemented extension point SD_SLS_MODIFY_HEAD.
  2. In "Plan Customer Projects", under Information tab, you adapt the custom field and activate it.
  3. Maintain the custom field and save.
  4. In VA03, you observe the custom field is saved under Custom Fields of sales order header.
  5. However, the custom field is not updated in table VBAK.

Cause

Not every project change triggers a sales order header change, so the extension point is not always called. 

Resolution

The field can be maintained directly as sales order header field which is under Project->Billing tab.

See Also

3015693 - Custom fields are empty in the billing document when using Project Billing functionality

Keywords

SD_SLS_MODIFY_HEAD, custom field, plan customer projects, information, billing, billing document request, BDR, sales order, SO, professional services, project, customer project, VBAK, flowing , KBA , SD-SLS-PBS , Project-Based Services in Sales Documents , CA-CPD-SS , S/4HANA Public Cloud – Professional Service Projects , Problem

Product

SAP S/4HANA Cloud Public Edition all versions